Increased processing times and errors for Universal-2

Incident Report for AssemblyAI

Resolved

We have continued to see processing times remain in the normal range and are now marking this issue as resolved.
Posted Apr 16, 2026 - 19:24 UTC

Monitoring

The root cause of the slowdown has been addressed and turnaround times have once again returned to the normal range. We will continue to monitor traffic going forward to ensure continued good performance.
Posted Apr 16, 2026 - 18:56 UTC

Identified

We have identified an issue that is causing elevated processing times for requests that are using Universal-2 for pre-recorded audio. Most requests are still completing successfully, but we are also seeing a small increase in errors as a result of some requests timing out. Our team has identified the root cause of this issue and is working to resolve it as quickly as possible. Request using Universal-3 Pro are unaffected by this issue.
Posted Apr 16, 2026 - 18:37 UTC
This incident affected: APIs (Asynchronous API).