Account information not update correctly

Incident Report for AssemblyAI

Resolved

We have continued to see good performance and previously affected users are reporting that the issues are resolved on their end as well so we are marking this issue as resolved.
Posted Feb 24, 2025 - 23:53 UTC

Identified

We have released a fix aimed to address the account issues we have been experiencing and are monitoring to ensure that the issue has been resolved.
Posted Feb 24, 2025 - 23:38 UTC

Investigating

We are currently investigating an issue that is causing account information to not update correctly. This can affect some of the information displayed in the dashboard including account balance, which in some edge cases involving recent payments can affect API usage.
Posted Feb 24, 2025 - 23:26 UTC
This incident affected: Billing.