Payment Processing Disruption

Incident Report for AssemblyAI

Resolved

We have continued to see payment being processed normally so we are marking this issue as resolved.
Posted May 17, 2025 - 17:41 UTC

Monitoring

Our billing provider looks to have resolved the issues that were affecting them, and we are once again seeing payments complete as expected. We are monitoring the situation to ensure good performance going forward.
Posted May 17, 2025 - 16:59 UTC

Identified

We are currently experiencing issues that are affecting customers' abilities to add funds to their accounts. This is affecting some new and existing users. Our team is actively investigating the problem and working with our payment processor to resolve this as quickly as possible.
Posted May 17, 2025 - 16:29 UTC
This incident affected: Billing.