Timeout on transcriptions using speaker labels

Incident Report for AssemblyAI

Postmortem

What happened
An issue related to our speaker diarization service caused certain requests to hang until they timed out. This lead to a backlog of requests to our async API creating a processing queue across our US transcription pipeline, which slowed and timed out transcription requests more broadly, including requests that were not using speaker diarization.


When
Impact ran from approximately 15:00 to 16:25 UTC on June 25, 2026 (about 1 hour 25 minutes). The most severe disruption was in the first 45 minutes (15:00–15:45 UTC); remaining delays and timeouts cleared shortly after. Full recovery was confirmed by ≈16:40 UTC.


What services were affected
On our US async API endpoint transcription requests during this window saw processing delays and timeouts.
Our EU async API endpoint was not affected and operated normally throughout.

Posted Jun 25, 2026 - 18:06 UTC

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 16:48 UTC

Update

Our API is continuing to recover and incoming transcriptions are returning to normal processing. We are continuing to monitor the situation.
Posted Jun 25, 2026 - 16:27 UTC

Update

The root cause has been addressed and our system is slowly working through the transcript backlog, which is causing slower processing on our US async endpoint.
Posted Jun 25, 2026 - 16:14 UTC

Monitoring

A fix has been implemented and our API is slowly beginning to recover normal processing.
Posted Jun 25, 2026 - 16:00 UTC

Identified

The issue has been identified and a fix has been released.
Posted Jun 25, 2026 - 15:38 UTC

Investigating

We are currently investigating an issue with async transcriptions on the US endpoint that use speaker labels. This is resulting in timeouts for all transcriptions with speaker labels enabled for files under 2 minutes long. This began at 15:00 UTC.
Posted Jun 25, 2026 - 15:37 UTC
This incident affected: APIs (Asynchronous API).