Degraded Async Transcription Performance

Incident Report for AssemblyAI

Resolved

The issue affecting async transcription processing has been fully resolved. All systems are operating normally. We apologize for the disruption to your workflows. If you have any questions, please reach out to support@assemblyai.com.
Posted Apr 09, 2026 - 21:49 UTC

Monitoring

The capacity constraint has been addressed and the transcription queue is actively clearing. Processing times should return to normal within the next few minutes. We are continuing to monitor to ensure stability.
Posted Apr 09, 2026 - 21:40 UTC

Identified

We are currently experiencing degraded async transcription performance. Some customers may see increased processing times or throttled requests. Our engineering team has identified the issue and is actively working to restore full capacity. We will continue to provide updates as more information becomes available.
Posted Apr 09, 2026 - 21:33 UTC
This incident affected: APIs (Asynchronous API) and AWS Cloud (Transcription Queue).