Account Creation Issues

Incident Report for AssemblyAI

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 00:29 UTC

Monitoring

Account creation and updates are once again working normally, but we are continuing to monitor the situation to ensure continued good performance.
Posted Oct 20, 2025 - 23:39 UTC

Identified

We are currently experiencing an issue with new account creation due to the ongoing AWS issues that may affect the ability of newly created accounts to use our API or Playground.
Posted Oct 20, 2025 - 23:00 UTC
This incident affected: Billing.