Realtime ASR Processing Slowdown

Incident Report for AssemblyAI

Resolved

We have continued to see good results and are now marking this issue as resolved. We suspect that only a small number of transcripts were affected as P50 and P90 response times were within reasonable thresholds throughout, with only P99 response times being affected initially.
Posted May 16, 2025 - 10:21 UTC

Monitoring

The system has been stabilized and we are continuing to monitor the results.
Posted May 16, 2025 - 09:49 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 16, 2025 - 09:48 UTC

Investigating

We are currently investigating an issue causing degraded turnaround times for the Realtime API due to a slowdown in ASR processing. More updates to come as we learn more.
Posted May 16, 2025 - 09:04 UTC
This incident affected: APIs (Realtime API).