We have continued to see good performance, and traffic is once again working normally so we are marking this issue as resolved.
Posted Jan 28, 2026 - 19:58 UTC
Monitoring
We are seeing significant signs of recovery and processing of queued transcripts. Our team will continue to monitor the situation.
Posted Jan 28, 2026 - 19:02 UTC
Identified
The team has identified the issue and it is caused by an AWS Operational Issue on their Amazon Elastic Compute Cloud (Ireland). Our team is in touch with AWS and monitoring the situation: https://health.aws.amazon.com/health/status
Posted Jan 28, 2026 - 18:39 UTC
Update
This issue is also affecting the EU DELETE endpoint. Some DELETE requests for transcriptions are resulting in an error.
Posted Jan 28, 2026 - 18:06 UTC
Investigating
Our team is actively investigating an issue that is causing increased latency for transcriptions using the EU endpoint for pre-recorded transcriptions. Customers may experience transcripts being queued. This is not affecting streaming usage on the EU endpoint.