This issue has been resolved and all dashboard information is now properly updating.
Posted Mar 10, 2025 - 18:43 UTC
Update
Usage data is once again starting to flow through the system, but the information backlog will take time to be completely processed. The current estimate is that it will take 1-1.5 hours to process this backlog. We will provide another update once all information has been processed.
Posted Mar 10, 2025 - 17:17 UTC
Identified
Our billing provider has identified the root cause of this issue and is working to resolve it.
Posted Mar 10, 2025 - 16:40 UTC
Investigating
We are currently working with our billing provider to address an issue that is causing certain dashboard information to not be updated as expected. This issue includes usage charts, spend charts, and balance info not reflecting current values. This issue should have no impact on API usage.
Posted Mar 10, 2025 - 16:39 UTC
This incident affected: Billing and Web (Dashboard).