Billing Issue Affecting Some Universal-3-Pro Users

Incident Report for AssemblyAI

Resolved

The billing issue that caused unexpected multiple auto-refill charges for a subset of Universal-3-Pro customers on February 28, 2025, has been resolved. Refunds have been issued to the affected customers.
Posted Feb 28, 2026 - 20:44 UTC

Investigating

We are aware of an issue that caused unexpected multiple auto-refill charges for a subset of customers using Universal-3-Pro today, February 28, 2025. Our team is actively investigating the root cause and working to resolve it as quickly as possible. We apologize for the inconvenience and will provide further updates as they become available.
Posted Feb 28, 2026 - 19:19 UTC
This incident affected: Billing.