Elevated connection errors when starting new Streaming sessions

Incident Report for AssemblyAI

Resolved

This increase in errors was inadvertantly caused by a change that was made around 8:30am PT, which was immediately reverted when our team noticed the increase in errors. We have continued to see good performance since that rollback and are now marking this issue as resolved.
Posted Jan 05, 2026 - 17:03 UTC

Investigating

We experienced a spike in connection issues for new streaming sessions between 8:30 and 8:35am PT. These errors affected requests for both NA and EU regions. These connection issues have subsided, but our team is working to ensure continued good performance.
Posted Jan 05, 2026 - 16:45 UTC
This incident affected: APIs (Streaming API).