This incident has been resolved. Async transcription processing times on the US endpoint have returned to normal ranges and webhook deliveries are operating normally.
Posted Jul 09, 2026 - 14:12 UTC
Monitoring
We have been monitoring the queue drain and transcription pickup delays caused by the backlog. Processing times are returning to normal ranges on the US endpoint and the backlog has cleared. We are continuing to monitor.
Posted Jul 09, 2026 - 14:10 UTC
Identified
We have identified the issue causing elevated processing times for async transcriptions on the US endpoint and have addressed the root cause. The system is recovering, but processing times remain elevated while the backlog clears. Webhook deliveries may also continue to be delayed.
Posted Jul 09, 2026 - 13:59 UTC
Investigating
We are seeing increased processing times for pre-recorded (async) transcriptions on the US endpoint. Webhook deliveries may also be delayed. We are currently investigating.